lighttpd < 1.4.35 Multiple Vulnerabilities

This script is Copyright (C) 2014-2016 Tenable Network Security, Inc.


Synopsis :

The remote web server is affected by multiple vulnerabilities.

Description :

According to its banner, the version of lighttpd running on the remote
host is prior to 1.4.35. It is, therefore, affected by the following
vulnerabilities :

- A SQL injection flaw exists in the 'mod_mysql_vhost'
module where user input passed using the hostname is not
properly sanitized. A remote attacker can exploit this
to inject or manipulate SQL queries, resulting in the
manipulation or disclosure of data. (CVE-2014-2323)

- A traverse outside of restricted path flaw exists with
the 'mod_evhost' and 'mod_simple_vhost' modules where
user input passed using the hostname is not properly
sanitized. A remote attacker can exploit this to gain
access to potentially sensitive data. (CVE-2014-2324)

Note that Nessus has not tested for these issues but has instead
relied only on the application's self-reported version number.

See also :

http://www.lighttpd.net/2014/3/12/1.4.35/
http://www.nessus.org/u?92dd0985
http://download.lighttpd.net/lighttpd/security/lighttpd_sa_2014_01.txt
http://www.nessus.org/u?c57451b6

Solution :

Upgrade to lighttpd version 1.4.35. Alternatively, apply the
vendor-supplied patch.

Risk factor :

High / CVSS Base Score : 7.5
(CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P)
CVSS Temporal Score : 6.2
(CVSS2#E:F/RL:OF/RC:ND)
Public Exploit Available : true

Family: Web Servers

Nessus Plugin ID: 73123 ()

Bugtraq ID: 66153
66157

CVE ID: CVE-2014-2323
CVE-2014-2324

Ready to Scan Unlimited IPs & Run Compliance Checks?

Upgrade to Nessus Professional today!

Buy Now

Combine the Power of Nessus with the Ease of Cloud

Start your free Nessus Cloud trial now!

Begin Free Trial