Amazon Linux AMI : socat (ALAS-2014-300)

This script is Copyright (C) 2014 Tenable Network Security, Inc.


Synopsis :

The remote Amazon Linux AMI host is missing a security update.

Description :

Stack-based buffer overflow in socat 1.3.0.0 through 1.7.2.2 and
2.0.0-b1 through 2.0.0-b6 allows local users to cause a denial of
service (segmentation fault) via a long server name in the
PROXY-CONNECT address in the command line.

See also :

http://www.nessus.org/u?bddcc7ba

Solution :

Run 'yum update socat' to update your system.

Risk factor :

Low / CVSS Base Score : 1.9
(CVSS2#AV:L/AC:M/Au:N/C:N/I:N/A:P)

Family: Amazon Linux Local Security Checks

Nessus Plugin ID: 72948 ()

Bugtraq ID:

CVE ID: CVE-2014-0019