Palo Alto Networks PAN-OS < 3.1.11 / 4.0.9 Multiple Vulnerabilities

This script is Copyright (C) 2014 Tenable Network Security, Inc.


Synopsis :

The remote host is affected by multiple vulnerabilities.

Description :

The remote host is running a version of Palo Alto Networks PAN-OS prior
to 3.1.11 / 4.0.9. It is, therefore, affected by multiple
vulnerabilities :

- A denial of service vulnerability exists that
potentially allows an authenticated attacker to crash
the device via a specially crafted command sent to the
CLI. (CVE-2012-6597 / PAN-SA-2012-0008)

- A vulnerability exists that potentially allows an
authenticated user to inject arbitrary shell commands
via the CLI. (CVE-2012-6604 / PAN-SA-2012-0015)

- A vulnerability exists that potentially allows an
authenticated user to inject arbitrary shell commands
via the CLI. (CVE-2012-6605 / PAN-SA-2012-0016)

See also :

https://securityadvisories.paloaltonetworks.com/Home/Detail/8
https://securityadvisories.paloaltonetworks.com/Home/Detail/15
https://securityadvisories.paloaltonetworks.com/Home/Detail/16

Solution :

Upgrade to PAN-OS version 3.1.11 / 4.0.9 or later.

Risk factor :

High / CVSS Base Score : 9.0
(CVSS2#AV:N/AC:L/Au:S/C:C/I:C/A:C)
CVSS Temporal Score : 6.7
(CVSS2#E:U/RL:OF/RC:C)
Public Exploit Available : false

Family: Palo Alto Local Security Checks

Nessus Plugin ID: 72823 ()

Bugtraq ID: 62116
62122
62127

CVE ID: CVE-2012-6597
CVE-2012-6604
CVE-2012-6605