Palo Alto Networks PAN-OS < 3.1.10 / 4.0.5 Multiple Command Injections

This script is Copyright (C) 2014 Tenable Network Security, Inc.


Synopsis :

The remote host is affected by multiple command injection
vulnerabilities.

Description :

The remote host is running a version of Palo Alto Networks PAN-OS prior
to 3.1.10 / 4.0.5. It is, therefore, affected by multiple command
injection vulnerabilities :

- A vulnerability exists that potentially allows an
authenticated user to inject arbitrary shell commands
via the CLI. (CVE-2012-6591 / PAN-SA-2012-0002)

- A vulnerability exists that potentially allows an
unauthenticated user to inject commands as root on the
device. (CVE-2012-6592 / PAN-SA-2012-0003)

See also :

https://securityadvisories.paloaltonetworks.com/Home/Detail/2
https://securityadvisories.paloaltonetworks.com/Home/Detail/3

Solution :

Upgrade to PAN-OS version 3.1.10 / 4.0.5 or later.

Risk factor :

Critical / CVSS Base Score : 10.0
(CVSS2#AV:N/AC:L/Au:N/C:C/I:C/A:C)
CVSS Temporal Score : 7.4
(CVSS2#E:U/RL:OF/RC:C)
Public Exploit Available : false

Family: Palo Alto Local Security Checks

Nessus Plugin ID: 72818 ()

Bugtraq ID: 62123
62125

CVE ID: CVE-2012-6591
CVE-2012-6592