Apache Tomcat 6.0.x < 6.0.39 Multiple Vulnerabilities

This script is Copyright (C) 2014-2016 Tenable Network Security, Inc.


Synopsis :

The remote Apache Tomcat server is affected by multiple
vulnerabilities.

Description :

According to its self-reported version number, the instance of Apache
Tomcat 6.0.x listening on the remote host is prior to 6.0.39. It is,
therefore, affected by the following vulnerabilities :

- The version of Java used to build the application
generates Javadoc containing a frame injection error.
(CVE-2013-1571)

- The fix for CVE-2005-2090 was not complete and the
application does not reject requests with multiple
Content-Length HTTP headers or with Content-Length
HTTP headers when using chunked encoding.
(CVE-2013-4286)

- The fix for CVE-2012-3544 was not complete and limits
are not properly applied to chunk extensions and
whitespaces in certain trailing headers. This error
allows denial of service attacks. (CVE-2013-4322)

- The application allows XML External Entity (XXE)
processing that discloses sensitive information.
(CVE-2013-4590)

- An error exists related to the 'disableURLRewriting'
configuration option and session IDs. (CVE-2014-0033)

Note that Nessus has not tested for these issues but has instead
relied only on the application's self-reported version number.

See also :

http://tomcat.apache.org/security-6.html#Fixed_in_Apache_Tomcat_6.0.39

Solution :

Upgrade to Apache Tomcat version 6.0.39 or later.

Risk factor :

Medium / CVSS Base Score : 4.3
(CVSS2#AV:N/AC:M/Au:N/C:P/I:N/A:N)
CVSS Temporal Score : 3.7
(CVSS2#E:ND/RL:OF/RC:C)
Public Exploit Available : false

Family: Web Servers

Nessus Plugin ID: 72690 ()

Bugtraq ID: 60634
65767
65768
65769
65773

CVE ID: CVE-2013-1571
CVE-2013-4286
CVE-2013-4322
CVE-2013-4590
CVE-2014-0033