Apple iOS 6.x < 6.1.6 'SSLVerifySignedServerKeyExchange' Certificate Validation Weakness

This script is Copyright (C) 2014 Tenable Network Security, Inc.


Synopsis :

The version of iOS running on the mobile device is affected by a
certificate validation weakness.

Description :

The mobile device is running a version of iOS that is 6.x prior to
version 6.1.6. It is, therefore, prone to an SSL certificate
validation weakness. This error could allow an attacker to spoof a
server and obtain sensitive information or modify secure content.

See also :

https://www.imperialviolet.org/2014/02/22/applebug.html
http://comments.gmane.org/gmane.comp.security.patch-managment/4004
http://support.apple.com/kb/HT6146
http://www.securityfocus.com/archive/1/531229/30/0/threaded

Solution :

Upgrade to iOS 6.1.6 or later.

Risk factor :

Medium / CVSS Base Score : 5.8
(CVSS2#AV:N/AC:M/Au:N/C:P/I:P/A:N)
CVSS Temporal Score : 5.0
(CVSS2#E:ND/RL:OF/RC:C)
Public Exploit Available : true

Family: Mobile Devices

Nessus Plugin ID: 72666 ()

Bugtraq ID: 65738

CVE ID: CVE-2014-1266