GLSA-201402-20 : KVIrc: Multiple vulnerabilities

This script is Copyright (C) 2014 Tenable Network Security, Inc.


Synopsis :

The remote Gentoo host is missing one or more security-related
patches.

Description :

The remote host is affected by the vulnerability described in GLSA-201402-20
(KVIrc: Multiple vulnerabilities)

Multiple vulnerabilities have been discovered in KVIrc. Please review
the CVE identifiers referenced below for details.

Impact :

A remote attacker could possibly execute arbitrary code with the
privileges of the process, cause a Denial of
Service condition, or overwrite arbitrary files.

Workaround :

There is no known workaround at this time.

See also :

http://www.gentoo.org/security/en/glsa/glsa-201402-20.xml

Solution :

All KVIrc users should upgrade to the latest version:
# emerge --sync
# emerge --ask --oneshot --verbose '>=net-irc/kvirc-4.1_pre4693'
NOTE: This is a legacy GLSA. Updates for all affected architectures are
available since July 29, 2010. It is likely that your system is already
no longer affected by this issue.

Risk factor :

Critical / CVSS Base Score : 10.0
(CVSS2#AV:N/AC:L/Au:N/C:C/I:C/A:C)
CVSS Temporal Score : 8.7
(CVSS2#E:ND/RL:OF/RC:C)
Public Exploit Available : true

Family: Gentoo Local Security Checks

Nessus Plugin ID: 72634 ()

Bugtraq ID: 40746
42026

CVE ID: CVE-2010-2451
CVE-2010-2452
CVE-2010-2785