Flash Player for Mac <= 11.7.700.261 / 12.0.0.44 Multiple Vulnerabilities (APSB14-07) (Mac OS X)

This script is Copyright (C) 2014 Tenable Network Security, Inc.


Synopsis :

The remote Mac OS X host has a browser plugin that is affected by
multiple vulnerabilities.

Description :

According to its version, the instance of Flash Player installed on
the remote Mac OS X host is equal or prior to 11.7.700.261 / 11.8.x /
11.9.x / 12.0.0.44. It is, therefore, potentially affected by
multiple vulnerabilities :

- A stack overflow vulnerability exists that could result
in arbitrary code execution. (CVE-2014-0498)

- A memory leak vulnerability exists that could be used
to aid in buffer overflow attacks by bypassing address
space layout randomization (ASLR). (CVE-2014-0499)

- A double free vulnerability exists that could result in
arbitrary code execution. (CVE-2014-0502)

See also :

http://www.zerodayinitiative.com/advisories/ZDI-14-040/
http://helpx.adobe.com/security/products/flash-player/apsb14-07.html

Solution :

Upgrade to Adobe Flash Player version 11.7.700.269 / 12.0.0.70 or
later.

Risk factor :

High / CVSS Base Score : 9.3
(CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C)
CVSS Temporal Score : 8.1
(CVSS2#E:ND/RL:OF/RC:C)
Public Exploit Available : true

Family: MacOS X Local Security Checks

Nessus Plugin ID: 72607 ()

Bugtraq ID: 65702
65703
65704

CVE ID: CVE-2014-0498
CVE-2014-0499
CVE-2014-0502