SuSE 11.2 / 11.3 Security Update : PHP5 (SAT Patch Numbers 8683 / 8684)

This script is Copyright (C) 2014 Tenable Network Security, Inc.


Synopsis :

The remote SuSE 11 host is missing one or more security updates.

Description :

This update fixes the following issues :

- memory corruption in openssl_parse_x509. (CVE-2013-6420)

- Heap buffer over-read in DateInterval. (CVE-2013-6712)

- man-in-the-middle attacks by specially crafting
certificates (CVE-2013-4248)

See also :

https://bugzilla.novell.com/show_bug.cgi?id=837746
https://bugzilla.novell.com/show_bug.cgi?id=842676
https://bugzilla.novell.com/show_bug.cgi?id=853045
https://bugzilla.novell.com/show_bug.cgi?id=854880
http://support.novell.com/security/cve/CVE-2013-4248.html
http://support.novell.com/security/cve/CVE-2013-6420.html
http://support.novell.com/security/cve/CVE-2013-6712.html

Solution :

Apply SAT patch number 8683 / 8684 as appropriate.

Risk factor :

High / CVSS Base Score : 7.5
(CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P)

Family: SuSE Local Security Checks

Nessus Plugin ID: 71965 ()

Bugtraq ID:

CVE ID: CVE-2013-4248
CVE-2013-6420
CVE-2013-6712