Flash Player for Mac <= 11.7.700.257 / 11.9.900.170 Multiple Vulnerabilities (APSB14-02)

This script is Copyright (C) 2014 Tenable Network Security, Inc.


Synopsis :

The remote Mac OS X host has a browser plugin that is affected by
multiple vulnerabilities.

Description :

According to its version, the instance of Flash Player installed on the
remote Mac OS X host is equal or prior to 11.7.700.257 / 11.8.x or
11.9.x equal or prior to 11.9.900.170. It is, therefore, potentially
affected by the following vulnerabilities :

- An unspecified vulnerability exists that can be used to
bypass Flash Player security protections.
(CVE-2014-0491)

- An unspecified vulnerability exists that can be used to
bypass memory address layout randomization.
(CVE-2014-0492)

See also :

http://www.zerodayinitiative.com/advisories/ZDI-14-014/
http://helpx.adobe.com/security/products/flash-player/apsb14-02.html

Solution :

Upgrade to Adobe Flash Player version 11.7.700.260 / 12.0.0.38 or
later.

Risk factor :

High / CVSS Base Score : 9.3
(CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C)
CVSS Temporal Score : 8.1
(CVSS2#E:ND/RL:OF/RC:C)
Public Exploit Available : true

Family: MacOS X Local Security Checks

Nessus Plugin ID: 71953 ()

Bugtraq ID: 64807
64810

CVE ID: CVE-2014-0491
CVE-2014-0492