RealVNC < 5.0.7 Multiple Local Privilege Escalations

This script is Copyright (C) 2014 Tenable Network Security, Inc.


Synopsis :

The remote host has an remote control application that is affected by
multiple local privilege escalation vulnerabilities.

Description :

The version of RealVNC on the remote host is earlier than 5.0.7. As
such, it is affected by multiple privilege escalation
vulnerabilities :

- A local privilege escalation vulnerability exists that
is triggered by a specially crafted argument to the
vncserver-x11 binary on UNIX / Linux. (CVE-2013-6886)

- A local privilege escalation vulnerability exists that
is triggered by a specially crafted argument to the Xvnc
binary on UNIX / Linux. (CVE-2013-6886)

- A local privilege escalation vulnerability exists that
is triggered by a specially crafted argument to the
vncserver binary on Mac OS X. (CVE-2013-6886)

See also :

http://www.realvnc.com/products/vnc/documentation/5.0/release-notes/

Solution :

Upgrade to RealVNC 5.0.7 or later.

Risk factor :

High / CVSS Base Score : 7.2
(CVSS2#AV:L/AC:L/Au:N/C:C/I:C/A:C)
CVSS Temporal Score : 6.3
(CVSS2#E:ND/RL:OF/RC:C)
Public Exploit Available : false

Family: Misc.

Nessus Plugin ID: 71884 ()

Bugtraq ID: 64560

CVE ID: CVE-2013-6886