OpenSSL 1.0.1 < 1.0.1f Multiple Vulnerabilities

This script is Copyright (C) 2014 Tenable Network Security, Inc.


Synopsis :

The remote service may be affected by multiple vulnerabilities.

Description :

According to its banner, the remote web server is running a version
of OpenSSL 1.0.1 prior to 1.0.1f. The OpenSSL library is, therefore,
reportedly affected by the following vulnerabilities :

- An error exists in the 'ssl3_take_mac' function in the
file 'ssl/s3_both.c' related to handling TLS handshake
traffic that could lead to denial of service attacks.
(CVE-2013-4353)

- An error exists in the 'ssl_get_algorithm2' function in
the file 'ssl/s3_lib.c' related to handling TLS 1.2
traffic that could lead to denial of service attacks.
(CVE-2013-6449)

- An error exists related to man-in-the-middle attackers
and handling DTLS processes that could lead to various
security bypasses. (CVE-2013-6450)

See also :

http://www.mail-archive.com/openssl-announce@openssl.org/msg00128.html
http://www.nessus.org/u?93ad3533
http://www.nessus.org/u?81124091
http://www.nessus.org/u?a4485220

Solution :

Upgrade to OpenSSL 1.0.1f or later.

Risk factor :

Medium / CVSS Base Score : 5.8
(CVSS2#AV:N/AC:M/Au:N/C:N/I:P/A:P)
CVSS Temporal Score : 5.0
(CVSS2#E:ND/RL:OF/RC:C)
Public Exploit Available : true

Family: Web Servers

Nessus Plugin ID: 71857 ()

Bugtraq ID: 64530
64618
64691

CVE ID: CVE-2013-4353
CVE-2013-6449
CVE-2013-6450