OpenSSL 1.0.0 < 1.0.0l DTLS Security Bypass

This script is Copyright (C) 2014 Tenable Network Security, Inc.


Synopsis :

The remote host may be affected by a security bypass vulnerability.

Description :

According to its banner, the remote web server is running a version
of OpenSSL 1.0.0 prior to 1.0.0l. The OpenSSL library is, therefore,
reportedly affected by a security bypass vulnerability related to
handling DTLS processes.

See also :

http://www.mail-archive.com/openssl-announce@openssl.org/msg00129.html
http://www.nessus.org/u?04f65a6b

Solution :

Upgrade to OpenSSL 1.0.0l or later.

Risk factor :

Medium / CVSS Base Score : 5.8
(CVSS2#AV:N/AC:M/Au:N/C:N/I:P/A:P)
CVSS Temporal Score : 5.0
(CVSS2#E:ND/RL:OF/RC:C)
Public Exploit Available : true

Family: Web Servers

Nessus Plugin ID: 71856 ()

Bugtraq ID: 64618

CVE ID: CVE-2013-6450