GLSA-201401-05 : ISC DHCP: Denial of Service

This script is Copyright (C) 2014 Tenable Network Security, Inc.


Synopsis :

The remote Gentoo host is missing one or more security-related
patches.

Description :

The remote host is affected by the vulnerability described in GLSA-201401-05
(ISC DHCP: Denial of Service)

ISC DHCP is vulnerable to a memory exhaustion attack involving regular
expressions sent by DHCP clients.

Impact :

A remote attacker could send a specially crafted request from a
malicious or spoofed client, potentially leading to a Denial of Service
condition.

Workaround :

There is no known workaround at this time.

See also :

http://www.gentoo.org/security/en/glsa/glsa-201401-05.xml

Solution :

All ISC DHCP users should upgrade to the latest version:
# emerge --sync
# emerge --ask --oneshot --verbose '>=net-misc/dhcp-4.2.5_p1'

Risk factor :

Medium / CVSS Base Score : 4.9
(CVSS2#AV:N/AC:H/Au:S/C:N/I:N/A:C)

Family: Gentoo Local Security Checks

Nessus Plugin ID: 71812 ()

Bugtraq ID:

CVE ID: CVE-2013-2494