GLSA-201312-15 : Tinyproxy: Denial of Service

This script is Copyright (C) 2013-2014 Tenable Network Security, Inc.


Synopsis :

The remote Gentoo host is missing one or more security-related
patches.

Description :

The remote host is affected by the vulnerability described in GLSA-201312-15
(Tinyproxy: Denial of Service)

A vulnerability has been discovered in the way how Tinyproxy works with
headers.

Impact :

A remote attacker could send a specially crafted request with too many
headers, possibly resulting in a Denial of Service condition.

Workaround :

There is no known workaround at this time.

See also :

http://www.gentoo.org/security/en/glsa/glsa-201312-15.xml

Solution :

All Tinyproxy users should upgrade to the latest version:
# emerge --sync
# emerge --ask --oneshot --verbose '>=net-proxy/tinyproxy-1.8.3-r3'

Risk factor :

Medium / CVSS Base Score : 5.0
(CVSS2#AV:N/AC:L/Au:N/C:N/I:N/A:P)
CVSS Temporal Score : 4.3
(CVSS2#E:ND/RL:OF/RC:C)
Public Exploit Available : false

Family: Gentoo Local Security Checks

Nessus Plugin ID: 71628 ()

Bugtraq ID: 55099

CVE ID: CVE-2012-3505