Ubuntu 10.04 LTS / 12.04 LTS / 12.10 / 13.04 / 13.10 : php5 vulnerabilities (USN-2055-1)

Ubuntu Security Notice (C) 2013 Canonical, Inc. / NASL script (C) 2013 Tenable Network Security, Inc.


Synopsis :

The remote Ubuntu host is missing one or more security-related patches.

Description :

Stefan Esser discovered that PHP incorrectly parsed certificates. An
attacker could use a malformed certificate to cause PHP to crash,
resulting in a denial of service, or possibly execute arbitrary code.
(CVE-2013-6420)

It was discovered that PHP incorrectly handled DateInterval objects.
An attacker could use this issue to cause PHP to crash, resulting in a
denial of service. (CVE-2013-6712).

Solution :

Update the affected libapache2-mod-php5, php5-cgi and / or php5-cli
packages.

Risk factor :

High / CVSS Base Score : 7.5
(CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P)
CVSS Temporal Score : 6.5
(CVSS2#E:ND/RL:OF/RC:C)
Public Exploit Available : false

Family: Ubuntu Local Security Checks

Nessus Plugin ID: 71394 ()

Bugtraq ID: 64018
64225

CVE ID: CVE-2013-6420
CVE-2013-6712