Debian DSA-2808-1 : openjpeg - several vulnerabilities

This script is Copyright (C) 2013-2015 Tenable Network Security, Inc.

Synopsis :

The remote Debian host is missing a security-related update.

Description :

Several vulnerabilities have been discovered in OpenJPEG, a JPEG 2000
image library, that may lead to denial of service (CVE-2013-1447 ) via
application crash or high memory consumption, possible code execution
through heap buffer overflows (CVE-2013-6045 ), information disclosure
(CVE-2013-6052 ), or yet another heap buffer overflow that only
appears to affect OpenJPEG 1.3 (CVE-2013-6054 ).

See also :

Solution :

Upgrade the openjpeg packages.

For the oldstable distribution (squeeze), these problems have been
fixed in version 1.3+dfsg-4+squeeze2.

For the stable distribution (wheezy), these problems have been fixed
in version 1.3+dfsg-4.7.

Risk factor :

High / CVSS Base Score : 7.5
CVSS Temporal Score : 6.5
Public Exploit Available : false

Family: Debian Local Security Checks

Nessus Plugin ID: 71180 ()

Bugtraq ID: 64109

CVE ID: CVE-2013-1447