Thunderbird < 24.1 NSS and NSPR Multiple Vulnerabilities (Mac OS X)

This script is Copyright (C) 2013 Tenable Network Security, Inc.

Synopsis :

The remote Mac OS X host contains a mail client that is potentially
affected by multiple vulnerabilities.

Description :

The installed version of Thunderbird is earlier than 24.1.1 and is,
therefore, potentially affected by the following vulnerabilities :

- An error exists related to handling input greater than
half the maximum size of the 'PRUint32' value.

- An error exists in the 'Null_Cipher' function in the
file 'ssl/ssl3con.c' related to handling invalid
handshake packets that could allow arbitrary code
execution. (CVE-2013-5605)

- An error exists in the 'CERT_VerifyCert' function in
the file 'lib/certhigh/certvfy.c' that could allow
invalid certificates to be treated as valid.

- An integer truncation error exists in the function
'PL_ArenaAllocate' in the Netscape Portable Runtime
(NSPR) library. (CVE-2013-5607)

See also :

Solution :

Upgrade to Thunderbird 24.1.1 or later.

Risk factor :

High / CVSS Base Score : 9.3
CVSS Temporal Score : 8.1
Public Exploit Available : false

Family: MacOS X Local Security Checks

Nessus Plugin ID: 71043 ()

Bugtraq ID: 63736

CVE ID: CVE-2013-1741