This script is Copyright (C) 2013-2014 Tenable Network Security, Inc.
The remote web server hosts a PHP application that is affected by a
cross-site scripting vulnerability.
The remote web server hosts a version of the Google Site Search Module
for Drupal that is version 6.x prior to 6.x-1.4 or 7.x prior to
7.x-1.10. As such, the application is affected by a cross-site
scripting vulnerability due to the application failing to properly
sanitize API data before returning it to the user. This could allow a
remote, unauthenticated attacker to create a specially crafted request
to execute arbitrary script code into a user's browser to be executed
within the security context of the affected site.
Note that Nessus has not tested for these issues but has instead
relied only on the application's self-reported version number.
See also :
Upgrade to Google Site Search version 6.x-1.4 / 7.x-1.10 or later.
Risk factor :
Medium / CVSS Base Score : 4.3
CVSS Temporal Score : 3.7
Public Exploit Available : true