Drupal Google Site Search Module API Data Handling XSS

This script is Copyright (C) 2013-2015 Tenable Network Security, Inc.

Synopsis :

The remote web server hosts a PHP application that is affected by a
cross-site scripting vulnerability.

Description :

The remote web server hosts a version of the Google Site Search module
for Drupal that is version 6.x prior to 6.x-1.4 or 7.x prior to
7.x-1.10. It is, therefore, affected by a cross-site scripting
vulnerability due to a failure to properly sanitize API data before
returning it to a user. This allows a remote, unauthenticated
attacker, via a specially crafted request to execute arbitrary script
code in a user's browser to be executed within the security context of
the affected site.

Note that Nessus has not tested for these issues but has instead
relied only on the application's self-reported version number.

See also :


Solution :

Upgrade to Google Site Search version 6.x-1.4 / 7.x-1.10 or later.

Risk factor :

Medium / CVSS Base Score : 4.3
CVSS Temporal Score : 3.7
Public Exploit Available : true

Family: CGI abuses : XSS

Nessus Plugin ID: 70920 ()

Bugtraq ID: 62495

CVE ID: CVE-2013-4384