Joomla! 2.5.x < 2.5.16 / 3.x < 3.1.6 Multiple XSS

This script is Copyright (C) 2013-2017 Tenable Network Security, Inc.


Synopsis :

The remote web server contains a PHP application that is affected by
multiple cross-site scripting vulnerabilities.

Description :

According to its self-reported version number, the Joomla!
installation running on the remote web server is 2.5.x prior to 2.5.16
or 3.x prior to 3.1.6. It is, therefore, affected by multiple
cross-site (XSS) scripting vulnerabilities, related to the
com_contact, com_weblinks, and com_newsfeeds components, due to
improper validation of input before returning it to users. An
unauthenticated, remote attacker can exploit these, via a specially
crafted request, to execute arbitrary script code in a user's browser
session.

Note that Nessus has not tested for these issues but has instead
relied only on the application's self-reported version number.

See also :

https://developer.joomla.org/security/570-core-xss-20131101.html
https://developer.joomla.org/security/571-core-xss-20131102.html
https://developer.joomla.org/security/572-core-xss-20131103.html
http://www.nessus.org/u?50f6d238
http://www.nessus.org/u?4b771e1b

Solution :

Upgrade to version Joomla! version 2.5.16 / 3.1.6 / 3.2.0 or later.
Alternatively, apply the patch referenced in the vendor advisory.

Risk factor :

Medium / CVSS Base Score : 4.3
(CVSS2#AV:N/AC:M/Au:N/C:N/I:P/A:N)
CVSS Temporal Score : 3.7
(CVSS2#E:ND/RL:OF/RC:C)
Public Exploit Available : true

Family: CGI abuses : XSS

Nessus Plugin ID: 70918 ()

Bugtraq ID: 63598

CVE ID:

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now