Quagga < 0.99.22.2 OSPF API Buffer Overflow

This script is Copyright (C) 2013-2014 Tenable Network Security, Inc.


Synopsis :

The remote service may be affected by a buffer overflow
vulnerability.

Description :

According to its self-reported version number, the installation of
Quagga listening on the remote host is potentially affected by a
stack-based buffer overflow that occurs in the OSPF API server
('ospf_api.c') when it receives an LSA larger than 1488 bytes.

The vulnerability is only present when Quagga is compiled with the
'--enable-opaque-lsa' flag and the OSPF API server is running (ospfd is
run with the '-a' parameter). Exploitation of this issue may lead to a
denial of service or arbitrary code execution.

See also :

http://lists.quagga.net/pipermail/quagga-dev/2013-July/010622.html
http://www.nessus.org/u?9cfd7251
http://nongnu.askapache.com//quagga/quagga-0.99.22.3.changelog.txt

Solution :

Upgrade to version 0.99.22.2 or later.

Risk factor :

Medium / CVSS Base Score : 4.3
(CVSS2#AV:A/AC:H/Au:N/C:P/I:P/A:P)
CVSS Temporal Score : 3.7
(CVSS2#E:ND/RL:OF/RC:ND)
Public Exploit Available : false

Family: Misc.

Nessus Plugin ID: 70761 ()

Bugtraq ID: 60955

CVE ID: CVE-2013-2236