GLSA-201310-16 : TPTEST: Arbitrary code execution

This script is Copyright (C) 2013-2014 Tenable Network Security, Inc.


Synopsis :

The remote Gentoo host is missing one or more security-related
patches.

Description :

The remote host is affected by the vulnerability described in GLSA-201310-16
(TPTEST: Arbitrary code execution)

The GetStatsFromLine() function in TPTEST is vulnerable to buffer
overflows from STATS lines with long email and pwd fields.

Impact :

A remote attacker could send a specially-crafted STATS line, possibly
resulting in arbitrary code execution or a Denial of Service condition.

Workaround :

There is no known workaround at this time.

See also :

http://www.gentoo.org/security/en/glsa/glsa-201310-16.xml

Solution :

All TPTEST users should upgrade to the latest version:
# emerge --sync
# emerge --ask --oneshot --verbose '>=net-analyzer/tptest-3.1.7-r2'

Risk factor :

Critical / CVSS Base Score : 10.0
(CVSS2#AV:N/AC:L/Au:N/C:C/I:C/A:C)
CVSS Temporal Score : 7.8
(CVSS2#E:POC/RL:OF/RC:ND)
Public Exploit Available : true

Family: Gentoo Local Security Checks

Nessus Plugin ID: 70651 ()

Bugtraq ID: 33785

CVE ID: CVE-2009-0650
CVE-2009-0659