Apple Remote Desktop < 3.5.4 / 3.7 Multiple Vulnerabilities (Mac OS X)

This script is Copyright (C) 2013 Tenable Network Security, Inc.


Synopsis :

The Mac OS X host has a remote management application that is
potentially affected by multiple vulnerabilities.

Description :

According to its version, the Apple Remote Desktop install on the
remote host is earlier than 3.5.4 / 3.7. As such, it is potentially
affected the following vulnerabilities :

- A format string vulnerability exists in Remote
Desktop's handling of a VNC username. (CVE-2013-5135)

- An information disclosure vulnerability exists because
Remote Desktop may use password authentication without
warning that the connection would be encrypted if a
third-party VNC server supports certain authentication
types. Note that this does not affect installs of
version 3.5.x or earlier. (CVE_2013-5136)

See also :

http://support.apple.com/kb/HT5997
http://support.apple.com/kb/HT5998
http://lists.apple.com/archives/security-announce/2013/Oct/msg00007.html
http://lists.apple.com/archives/security-announce/2013/Oct/msg00008.html

Solution :

Upgrade to Apple Remote Desktop 3.5.4 / 3.7 or later.

Risk factor :

High / CVSS Base Score : 9.3
(CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C)
CVSS Temporal Score : 8.1
(CVSS2#E:ND/RL:OF/RC:C)
Public Exploit Available : false

Family: MacOS X Local Security Checks

Nessus Plugin ID: 70609 ()

Bugtraq ID: 63284
63286

CVE ID: CVE-2013-5135
CVE-2013-5136