GLSA-201310-10 : PolarSSL: Multiple vulnerabilities

This script is Copyright (C) 2013-2014 Tenable Network Security, Inc.


Synopsis :

The remote Gentoo host is missing one or more security-related
patches.

Description :

The remote host is affected by the vulnerability described in GLSA-201310-10
(PolarSSL: Multiple vulnerabilities)

Multiple vulnerabilities have been discovered in PolarSSL. Please review
the CVE identifiers referenced below for details.

Impact :

A remote attacker might be able to cause Denial of Service, conduct a
man-in-the middle attack, compromise an encrypted communication channel,
or obtain sensitive information.

Workaround :

There is no known workaround at this time.

See also :

http://www.gentoo.org/security/en/glsa/glsa-201310-10.xml

Solution :

All PolarSSL users should upgrade to the latest version:
# emerge --sync
# emerge --ask --oneshot --verbose '>=net-libs/polarssl-1.3.0'

Risk factor :

Medium / CVSS Base Score : 4.3
(CVSS2#AV:N/AC:M/Au:N/C:N/I:N/A:P)
CVSS Temporal Score : 3.7
(CVSS2#E:ND/RL:OF/RC:C)
Public Exploit Available : false

Family: Gentoo Local Security Checks

Nessus Plugin ID: 70486 ()

Bugtraq ID: 46670
53610
57776
57778
61764
62771

CVE ID: CVE-2011-1923
CVE-2012-2130
CVE-2013-0169
CVE-2013-1621
CVE-2013-4623
CVE-2013-5915