IBM Informix Dynamic Server 11.50.x / 11.70.x < 11.70.xC7 RCE (credentialed check)

This script is Copyright (C) 2013-2017 Tenable Network Security, Inc.


Synopsis :

A database server installed on the remote host is affected by a remote
code execution vulnerability.

Description :

The version of IBM Informix Dynamic Server installed on the remote
host is 11.50.x or 11.70.x prior to 11.70.xC7. It is, therefore,
affected by a remote code execution vulnerability in the
'genxmlqueryhdr' and genxmlquery' XML functions due to an overflow
condition. An authenticated, remote attacker can exploit this, via a
specially crafted statement, to cause a denial of service condition or
the execution of arbitrary code.

See also :

http://www-01.ibm.com/support/docview.wss?uid=swg21618994

Solution :

Upgrade to IBM Informix Dynamic Server version 11.70.xC7 or later.

Risk factor :

High / CVSS Base Score : 9.0
(CVSS2#AV:N/AC:L/Au:S/C:C/I:C/A:C)
CVSS Temporal Score : 6.7
(CVSS2#E:U/RL:OF/RC:C)
Public Exploit Available : false

Family: Databases

Nessus Plugin ID: 70098 ()

Bugtraq ID: 56857

CVE ID: CVE-2012-4857

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now