Junos Pulse Secure IVE / UAC OS Multiple SSL Vulnerabilities

This script is Copyright (C) 2013-2014 Tenable Network Security, Inc.


Synopsis :

The remote device is missing a vendor-supplied security patch.

Description :

According to its self-reported version, the version of IVE / UAC OS
running on the remote host may be affected by multiple vulnerabilities :

- Remote attackers may be able to trigger buffer overflow
vulnerabilities on the OpenSSL libraries by sending
specially crafted DER data, resulting in memory
corruption. (CVE-2012-2131)

- A weakness in the OpenSSL library leaves it vulnerable
to an attack that could allow a third party to recover
(fully or partially) the plaintext from encrypted
traffic. (CVE-2013-0169)

- A flaw in OCSP signature verification in the OpenSSL
library allows remote OCSP servers to cause a denial of
service condition with an invalid key. (CVE-2013-0166)

See also :

http://kb.juniper.net/InfoCenter/index?page=content&id=JSA10591

Solution :

Upgrade to Juniper IVE/UAC OS version 7.1r15 / 7.2r11 / 7.3r6 / 7.4r3 /
4.1r8.1 / 4.2r5.1 / 4.3r6 / 4.4r3 or later.

Risk factor :

High / CVSS Base Score : 7.5
(CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P)
CVSS Temporal Score : 5.9
(CVSS2#E:POC/RL:OF/RC:C)
Public Exploit Available : true

Family: Misc.

Nessus Plugin ID: 69987 ()

Bugtraq ID: 53212
57778
60268

CVE ID: CVE-2012-2131
CVE-2013-0166
CVE-2013-0169