Mac OS X : Apple Safari < 5.1.10 Memory Corruptions

This script is Copyright (C) 2013-2015 Tenable Network Security, Inc.

Synopsis :

The remote host contains a web browser that is affected by two memory
corruption vulnerabilities.

Description :

The version of Apple Safari installed on the remote Mac OS X 10.6 host
is earlier than 5.1.10. It is, therefore, potentially affected by two
memory corruption vulnerabilities in JavaScriptCore's JSArray::sort()
method. By tricking a user into visiting a malicious website, an
attacker could leverage these issues to cause an application crash or
to execute arbitrary code.

See also :

Solution :

Upgrade to Apple Safari 5.1.10 or later.

Risk factor :

Medium / CVSS Base Score : 6.8
CVSS Temporal Score : 5.0
Public Exploit Available : true

Family: MacOS X Local Security Checks

Nessus Plugin ID: 69879 ()

Bugtraq ID: 56362

CVE ID: CVE-2012-3748