Amazon Linux AMI : nginx (ALAS-2013-189)

This script is Copyright (C) 2013-2014 Tenable Network Security, Inc.


Synopsis :

The remote Amazon Linux AMI host is missing a security update.

Description :

http/modules/ngx_http_proxy_module.c in nginx 1.1.4 through 1.2.8 and
1.3.0 through 1.4.0, when proxy_pass is used with untrusted HTTP
servers, allows remote attackers to cause a denial of service (crash)
and obtain sensitive information from worker process memory via a
crafted proxy response, a similar vulnerability to CVE-2013-2028 .

See also :

http://www.nessus.org/u?f18d400b

Solution :

Run 'yum update nginx' to update your system.

Risk factor :

Medium / CVSS Base Score : 5.8
(CVSS2#AV:N/AC:M/Au:N/C:P/I:N/A:P)

Family: Amazon Linux Local Security Checks

Nessus Plugin ID: 69748 ()

Bugtraq ID:

CVE ID: CVE-2013-2070