Amazon Linux AMI : libpng Buffer Overflow Vulnerability (ALAS-2012-49)

This script is Copyright (C) 2013-2014 Tenable Network Security, Inc.


Synopsis :

The remote Amazon Linux AMI host is missing a security update.

Description :

A heap-based buffer overflow flaw was found in libpng. An attacker
could create a specially crafted PNG image that, when opened, could
cause an application using libpng to crash or, possibly, execute
arbitrary code with the privileges of the user running the
application.

See also :

http://www.nessus.org/u?d632230e

Solution :

Run 'yum update libpng' to update your system.

Risk factor :

High / CVSS Base Score : 7.5
(CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P)

Family: Amazon Linux Local Security Checks

Nessus Plugin ID: 69656 ()

Bugtraq ID:

CVE ID: CVE-2011-3026