Amazon Linux AMI : puppet Multiple Vulnerabilities (ALAS-2011-11)

This script is Copyright (C) 2013 Tenable Network Security, Inc.


Synopsis :

The remote Amazon Linux AMI host is missing a security update.

Description :

The MITRE CVE database describes these issues as :

Puppet 2.7.x before 2.7.5, 2.6.x before 2.6.11, and 0.25.x allows
local users to overwrite arbitrary files via a symlink attack on the
.k5login file.

Puppet 2.7.x before 2.7.5, 2.6.x before 2.6.11, and 0.25.x, when
running in --edit mode, uses a predictable file name, which allows
local users to run arbitrary Puppet code or trick a user into editing
arbitrary files.

See also :

https://admin.fedoraproject.org/updates/puppet-2.6.6-3.el5
http://www.nessus.org/u?1dd8d12b

Solution :

Run 'yum upgrade puppet' to upgrade your system.

Risk factor :

Medium / CVSS Base Score : 6.3
(CVSS2#AV:L/AC:M/Au:N/C:N/I:C/A:C)

Family: Amazon Linux Local Security Checks

Nessus Plugin ID: 69570 ()

Bugtraq ID:

CVE ID: CVE-2011-3869
CVE-2011-3870
CVE-2011-3871