Amazon Linux AMI : freetype Input Validation Flaws (ALAS-2011-08)

This script is Copyright (C) 2013-2014 Tenable Network Security, Inc.


Synopsis :

The remote Amazon Linux AMI host is missing a security update.

Description :

The MITRE CVE database describes CVE-2011-3256 as :

FreeType 2 before 2.4.7, as used in CoreGraphics in Apple iOS before
5, Mandriva Enterprise Server 5, and possibly other products, allows
remote attackers to execute arbitrary code or cause a denial of
service (memory corruption) via a crafted font, a different
vulnerability than CVE-2011-0226.

See also :

http://www.nessus.org/u?b5c5d9db

Solution :

Run 'yum upgrade freetype' to upgrade your system.

Risk factor :

Medium / CVSS Base Score : 4.3
(CVSS2#AV:N/AC:M/Au:N/C:N/I:P/A:N)

Family: Amazon Linux Local Security Checks

Nessus Plugin ID: 69567 ()

Bugtraq ID:

CVE ID: CVE-2011-3256