GLSA-201309-01 : Cyrus-SASL: Denial of Service

This script is Copyright (C) 2013-2014 Tenable Network Security, Inc.


Synopsis :

The remote Gentoo host is missing one or more security-related
patches.

Description :

The remote host is affected by the vulnerability described in GLSA-201309-01
(Cyrus-SASL: Denial of Service)

In the GNU C Library (glibc) from version 2.17 onwards, the crypt()
function call can return NULL when the salt violates specifications or
the system is in FIPS-140 mode and a DES or MD5 hashed password is
passed. When Cyrus-SASL&rsquo
s authentication mechanisms call crypt(), a
NULL may be returned.

Impact :

A remote attacker could trigger this vulnerability to cause a Denial of
Service condition.

Workaround :

There is no known workaround at this time.

See also :

http://www.gentoo.org/security/en/glsa/glsa-201309-01.xml

Solution :

All Cyrus-SASL users should upgrade to the latest version:
# emerge --sync
# emerge --ask --oneshot --verbose '>=dev-libs/cyrus-sasl-2.1.26-r3'

Risk factor :

Medium / CVSS Base Score : 4.3
(CVSS2#AV:N/AC:M/Au:N/C:N/I:N/A:P)
CVSS Temporal Score : 3.7
(CVSS2#E:ND/RL:OF/RC:C)
Public Exploit Available : true

Family: Gentoo Local Security Checks

Nessus Plugin ID: 69538 ()

Bugtraq ID: 61164

CVE ID: CVE-2013-4122