Thunderbird < 17.0.8 Multiple Vulnerabilities (Mac OS X)

This script is Copyright (C) 2013-2015 Tenable Network Security, Inc.

Synopsis :

The remote Mac OS X host contains a mail client that is potentially
affected by multiple vulnerabilities.

Description :

The installed version of Thunderbird is earlier than 17.0.8 and is,
therefore, potentially affected by the following vulnerabilities :

- Various errors exist that could allow memory corruption
conditions. (CVE-2013-1701, CVE-2013-1702)

- Use-after-free errors exist related to DOM modification
when using 'SetBody' and generating a 'Certificate
Request Message'. (CVE-2013-1704, CVE-2013-1705)

- An error exists in the function 'nsCString::CharAt'
that could allow application crashes when decoding
specially crafted WAV audio files. (CVE-2013-1708)

- Unspecified errors exist related to HTML frames and
history handling, 'XrayWrappers', JavaScript URI
handling and web workers using 'XMLHttpRequest' that
could allow cross-site scripting attacks.
(CVE-2013-1709, CVE-2013-1711, CVE-2013-1713,

- An unspecified error exists related to generating
'Certificate Request Message Format' (CRMF) requests
that could allow cross-site scripting attacks.

- An error exists related to Java applets and 'file:///'
URIs that could allow read-only access to arbitrary
files. (CVE-2013-1717)

See also :

Solution :

Upgrade to Thunderbird 17.0.8 or later.

Risk factor :

High / CVSS Base Score : 9.3
CVSS Temporal Score : 8.1
Public Exploit Available : true