Multiple Vulnerabilities in Cisco Intrusion Prevention System Software (cisco-sa-20130717-ips)

This script is Copyright (C) 2013 Tenable Network Security, Inc.


Synopsis :

The remote security appliance is missing a vendor-supplied patch.

Description :

According to its self-reported version, the version of the Cisco
Intrusion Prevention System Software running on the remote host has the
following vulnerabilities :

- The IP stack in Cisco IPS Software could allow remote
attackers to cause a denial of service (DoS) condition
via malformed IPv4 packets. (CVE-2013-1243)

- Cisco IPS Software could allow remote attackers to cause
a DoS condition via fragmented IPv4 or IPv6 packets.
(CVE-2013-1218)

- Cisco IPS Software on some IPS NME devices could allow
remote attackers to cause a DoS condition via malformed
IPv4 packets that trigger incorrect memory allocation.
(CVE-2013-3410)

- The IDSM-2 drivers in Cisco IPS Software on Cisco
Catalyst 6500 devices with an IDSM-2 module could allow
remote attackers to cause a DoS condition via malformed
IPv4 TCP packets. (CVE-2013-3411)

See also :

http://www.nessus.org/u?ab63f245

Solution :

Apply the relevant update referenced in Cisco Security Advisory
cisco-sa-20130717-ips.

Risk factor :

High / CVSS Base Score : 7.8
(CVSS2#AV:N/AC:L/Au:N/C:N/I:N/A:C)
CVSS Temporal Score : 7.0
(CVSS2#E:F/RL:W/RC:C)
Public Exploit Available : true

Family: CISCO

Nessus Plugin ID: 69103 ()

Bugtraq ID: 61294
61299
61300
61301

CVE ID: CVE-2013-1218
CVE-2013-1243
CVE-2013-3410
CVE-2013-3411