FreeBSD : subversion -- remotely triggerable 'Assertion failed' DoS vulnerability or read overflow. (2ae24334-f2e6-11e2-8346-001e8c75030d)

This script is Copyright (C) 2013 Tenable Network Security, Inc.


Synopsis :

The remote FreeBSD host is missing one or more security-related
updates.

Description :

Subversion Project reports :

Subversion's mod_dav_svn Apache HTTPD server module will trigger an
assertion on some requests made against a revision root. This can lead
to a DoS. If assertions are disabled it will trigger a read overflow
which may cause a SEGFAULT (or equivalent) or undefined behavior.

Commit access is required to exploit this.

See also :

http://subversion.apache.org/security/CVE-2013-4131-advisory.txt
http://www.nessus.org/u?aa69d18c

Solution :

Update the affected packages.

Risk factor :

Medium / CVSS Base Score : 4.0
(CVSS2#AV:N/AC:L/Au:S/C:N/I:N/A:P)

Family: FreeBSD Local Security Checks

Nessus Plugin ID: 69052 ()

Bugtraq ID:

CVE ID: CVE-2013-4131