Squid 3.x < 3.2.12 / 3.3.x < 3.3.7 idnsALookup HTTP Request DoS

This script is Copyright (C) 2013-2014 Tenable Network Security, Inc.


Synopsis :

The remote proxy server is affected by a denial of service
vulnerability.

Description :

According to its banner, the version of Squid running on the remote
host is 3.x prior to 3.2.12 or 3.3.x prior to 3.3.7 and is, therefore,
affected by a denial of service vulnerability. A buffer overflow exists
in the 'idnsALookup' function in the file 'dns_internal.cc' that could
allow specially crafted HTTP requests that could result in a denial of
service.

Note that Nessus has relied only on the version in the proxy server's
banner, which is not updated by the patch that the project has released
to address this issue. If this patch has been applied properly and the
service has been restarted, consider this to be a false positive.

See also :

http://www.squid-cache.org/Advisories/SQUID-2013_2.txt
http://www.nessus.org/u?7d4a3221
http://www.nessus.org/u?01ebdd34
http://www.nessus.org/u?04f9aba0
http://www.nessus.org/u?89d9d13f

Solution :

Either upgrade to Squid version 3.2.12 / 3.3.7 or later, or apply the
vendor-supplied patch.

Risk factor :

Medium / CVSS Base Score : 5.0
(CVSS2#AV:N/AC:L/Au:N/C:N/I:N/A:P)
CVSS Temporal Score : 4.3
(CVSS2#E:ND/RL:OF/RC:C)
Public Exploit Available : false

Family: Firewalls

Nessus Plugin ID: 69041 ()

Bugtraq ID: 61111

CVE ID: CVE-2013-4115