MySQL 5.6.x < 5.6.12 Multiple Vulnerabilities

This script is Copyright (C) 2013-2014 Tenable Network Security, Inc.


Synopsis :

The remote database server may be affected by multiple
vulnerabilities.

Description :

The version of MySQL installed on the remote host is 5.6.x older than
5.6.12. As such, it is reportedly affected by vulnerabilities in the
following components :

- Audit Log
- Data Manipulation Language
- Full Text Search
- GIS
- InnoDB
- Locking
- MemCached
- Server Optimizer
- Server Privileges
- Server Replication
- XA Transactions

See also :

http://dev.mysql.com/doc/relnotes/mysql/5.6/en/news-5-6-12.html
http://www.nessus.org/u?96e69d66
http://www.nessus.org/u?532e14d2

Solution :

Upgrade to MySQL version 5.6.12 or later.

Risk factor :

Medium / CVSS Base Score : 6.8
(CVSS2#AV:N/AC:L/Au:S/C:N/I:N/A:C)
CVSS Temporal Score : 5.9
(CVSS2#E:ND/RL:OF/RC:C)
Public Exploit Available : false