Oracle Linux 4 / 5 : xmlsec1 (ELSA-2011-0486)

This script is Copyright (C) 2013 Tenable Network Security, Inc.


Synopsis :

The remote Oracle Linux host is missing one or more security updates.

Description :

From Red Hat Security Advisory 2011:0486 :

Updated xmlsec1 packages that fix one security issue and one bug are
now available for Red Hat Enterprise Linux 4 and 5.

The Red Hat Security Response Team has rated this update as having
moderate security impact. A Common Vulnerability Scoring System (CVSS)
base score, which gives a detailed severity rating, is available from
the CVE link in the References section.

The XML Security Library is a C library based on libxml2 and OpenSSL
that implements the XML Digital Signature and XML Encryption
standards.

A flaw was found in the way xmlsec1 handled XML files that contain an
XSLT transformation specification. A specially-crafted XML file could
cause xmlsec1 to create or overwrite an arbitrary file while
performing the verification of a file's digital signature.
(CVE-2011-1425)

Red Hat would like to thank Nicolas Grégoire and Aleksey Sanin for
reporting this issue.

This update also fixes the following bug :

* xmlsec1 previously used an incorrect search path when searching for
crypto plug-in libraries, possibly trying to access such libraries
using a relative path. (BZ#558480, BZ#700467)

Users of xmlsec1 should upgrade to these updated packages, which
contain backported patches to correct these issues. After installing
the update, all running applications that use the xmlsec1 library must
be restarted for the update to take effect.

See also :

https://oss.oracle.com/pipermail/el-errata/2011-May/002119.html
https://oss.oracle.com/pipermail/el-errata/2011-May/002118.html

Solution :

Update the affected xmlsec1 packages.

Risk factor :

Medium / CVSS Base Score : 5.1
(CVSS2#AV:N/AC:H/Au:N/C:P/I:P/A:P)
CVSS Temporal Score : 4.2
(CVSS2#E:F/RL:OF/RC:C)
Public Exploit Available : true

Family: Oracle Linux Local Security Checks

Nessus Plugin ID: 68269 ()

Bugtraq ID: 47135

CVE ID: CVE-2011-1425