Oracle Linux 5 : icu (ELSA-2009-1122)

This script is Copyright (C) 2013 Tenable Network Security, Inc.


Synopsis :

The remote Oracle Linux host is missing one or more security updates.

Description :

From Red Hat Security Advisory 2009:1122 :

Updated icu packages that fix a security issue are now available for
Red Hat Enterprise Linux 5.

This update has been rated as having moderate security impact by the
Red Hat Security Response Team.

The International Components for Unicode (ICU) library provides robust
and full-featured Unicode services.

A flaw was found in the way ICU processed certain, invalid byte
sequences during Unicode conversion. If an application used ICU to
decode malformed, multibyte character data, it may have been possible
to bypass certain content protection mechanisms, or display
information in a manner misleading to the user. (CVE-2009-0153)

All users of icu should upgrade to these updated packages, which
contain backported patches to resolve this issue.

See also :

https://oss.oracle.com/pipermail/el-errata/2009-June/001053.html

Solution :

Update the affected icu packages.

Risk factor :

Medium / CVSS Base Score : 4.3
(CVSS2#AV:N/AC:M/Au:N/C:N/I:P/A:N)

Family: Oracle Linux Local Security Checks

Nessus Plugin ID: 67878 ()

Bugtraq ID:

CVE ID: CVE-2009-0153