Oracle Linux 3 / 4 : ruby (ELSA-2006-0604 / ELSA-2006-0729)

This script is Copyright (C) 2013 Tenable Network Security, Inc.


Synopsis :

The remote Oracle Linux host is missing a security update.

Description :

Updated ruby packages that fix security issues are now available.

This update has been rated as having moderate security impact by the Red
Hat Security Response Team.

Ruby is an interpreted scripting language for object-oriented
programming.

Users of Ruby should upgrade to these updated packages which contain
backported patches and are not vulnerable to these issues.


From Red Hat Security Advisory 2006:0604 :

A number of flaws were found in the safe-level restrictions in Ruby. It
was possible for an attacker to create a carefully crafted malicious
script that can allow the bypass of certain safe-level restrictions.
(CVE-2006-3694)


From Red Hat Security Advisory 2006:0729 :

A flaw was discovered in the way Ruby's CGI module handles certain
multipart/form-data MIME data. If a remote attacker sends a specially
crafted multipart-form-data request, it is possible to cause the ruby
CGI script to enter an infinite loop, causing a denial of service.
(CVE-2006-5467)

See also :

https://oss.oracle.com/pipermail/el-errata/2006-November/000018.html

Solution :

Update the affected ruby packages.

Risk factor :

Medium / CVSS Base Score : 6.4
(CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:N)

Family: Oracle Linux Local Security Checks

Nessus Plugin ID: 67399 ()

Bugtraq ID:

CVE ID: CVE-2006-3694
CVE-2006-5467