ModSecurity < 2.7.3 XML External Entity (XXE) Data Parsing Arbitrary File Disclosure

This script is Copyright (C) 2013-2014 Tenable Network Security, Inc.


Synopsis :

The remote web application firewall may be affected by a file
disclosure vulnerability.

Description :

According to its banner, the version of ModSecurity installed on the
remote host is earlier than 2.7.3. It is, therefore, potentially
affected by a file disclosure vulnerability. An improperly configured
XML parser could allow untrusted XML entities from external sources to
be accepted, thus leading to possible arbitrary file disclosure.

It could also be possible for internal network servers to receive
unauthorized requests. Denial of service conditions are also possible.

Note that Nessus did not actually test for this issue, but instead has
relied on the version in the server's banner.

See also :

http://seclists.org/oss-sec/2013/q2/5
https://github.com/SpiderLabs/ModSecurity/blob/master/CHANGES
http://www.nessus.org/u?13229997

Solution :

Upgrade to ModSecurity version 2.7.3 or later.

Risk factor :

High / CVSS Base Score : 7.5
(CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P)
CVSS Temporal Score : 6.2
(CVSS2#E:F/RL:OF/RC:C)
Public Exploit Available : true

Family: Firewalls

Nessus Plugin ID: 67127 ()

Bugtraq ID: 58810

CVE ID: CVE-2013-1915