ModSecurity < 2.5.9 Multipart Request Header Name DoS

This script is Copyright (C) 2013-2014 Tenable Network Security, Inc.


Synopsis :

The remote web application firewall may be affected by a denial of
service vulnerability.

Description :

According to its banner, the version of ModSecurity installed on the
remote host is earlier than 2.5.9. It is, therefore, potentially
affected by a denial of service vulnerability. An error exists related
to multipart form HTTP POST requests with a missing part header name
that could allow an attacker to crash the application.

Note that Nessus did not actually test for this issue, but instead has
relied on the version in the server's banner.

See also :

http://archives.neohapsis.com/archives/bugtraq/2009-03/0195.html

Solution :

Upgrade to ModSecurity version 2.5.9 or later.

Risk factor :

High / CVSS Base Score : 7.8
(CVSS2#AV:N/AC:L/Au:N/C:N/I:N/A:C)
CVSS Temporal Score : 6.4
(CVSS2#E:F/RL:OF/RC:C)
Public Exploit Available : true

Family: Firewalls

Nessus Plugin ID: 67125 ()

Bugtraq ID: 34096

CVE ID: CVE-2009-1902