Gallery 3.0.x < 3.0.8 Multiple XSS

This script is Copyright (C) 2013-2014 Tenable Network Security, Inc.


Synopsis :

The remote web server contains a PHP application that is affected by
multiple cross-site scripting vulnerabilities.

Description :

According to its version number, the Gallery install hosted on the
remote web server contains cross-site scripting vulnerabilities in the
'uploadify.swf' and 'flowplay.swf' files, where URL fragments and
parameters are not properly sanitized when called via direct requests.
An attacker may be able to leverage these issues to inject arbitrary
HTML and script code into a user's browser to be executed within the
security context of the affected site.

Note that Nessus has not tested for these issues, but instead has relied
only on the application's self-reported version number.

See also :

http://seclists.org/oss-sec/2013/q2/458
http://galleryproject.org/gallery_3_0_8

Solution :

Upgrade to Gallery 3.0.8 or later.

Risk factor :

Medium / CVSS Base Score : 4.3
(CVSS2#AV:N/AC:M/Au:N/C:N/I:P/A:N)
CVSS Temporal Score : 3.6
(CVSS2#E:F/RL:OF/RC:C)
Public Exploit Available : true

Family: CGI abuses : XSS

Nessus Plugin ID: 66933 ()

Bugtraq ID: 60313

CVE ID: CVE-2013-2138