Ubuntu 12.04 LTS / 12.10 / 13.04 : puppet vulnerability (USN-1886-1)

Ubuntu Security Notice (C) 2013 Canonical, Inc. / NASL script (C) 2013 Tenable Network Security, Inc.


Synopsis :

The remote Ubuntu host is missing a security-related patch.

Description :

It was discovered that Puppet incorrectly handled YAML payloads. An
attacker on an untrusted client could use this issue to execute
arbitrary code on the master.

Solution :

Update the affected puppet-common package.

Risk factor :

High / CVSS Base Score : 7.5
(CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P)

Family: Ubuntu Local Security Checks

Nessus Plugin ID: 66924 ()

Bugtraq ID:

CVE ID: CVE-2013-3567