nginx ngx_http_proxy_module.c Multiple Vulnerabilities

This script is Copyright (C) 2013-2016 Tenable Network Security, Inc.

Synopsis :

The remote web server is affected by multiple vulnerabilities.

Description :

According to its Server response header, the installed version of nginx
is 1.3.x, greater than or equal to 1.3.9, or 1.4.x prior to 1.4.1. It
is, therefore, affected by multiple vulnerabilities :

- A stack-based buffer overflow in 'ngx_http_parse.c' may
allow a remote attacker to execute arbitrary code or
trigger a denial of service condition via a specially
crafted HTTP request. This vulnerability only affects
versions greater than or equal to 1.3.9 and less than
1.4.1. (CVE-2013-2028)

- A memory disclosure vulnerability in 'ngx_http_parse.c'
affects servers that use 'proxy_pass' to untrusted
upstream servers. This issue can be triggered by a
remote attacker via a specially crafted HTTP request.
Failed attempts may result in a denial of service
condition. (CVE-2013-2070)

See also :

Solution :

Either apply the patch manually or upgrade to nginx 1.4.1 / 1.5.0 or

Risk factor :

Critical / CVSS Base Score : 10.0
CVSS Temporal Score : 7.8
Public Exploit Available : true

Family: Web Servers

Nessus Plugin ID: 66672 ()

Bugtraq ID: 59699

CVE ID: CVE-2013-2028

Ready to Scan Unlimited IPs & Run Compliance Checks?

Upgrade to Nessus Professional today!

Buy Now

Combine the Power of Nessus with the Ease of Cloud

Start your free Nessus Cloud trial now!

Begin Free Trial