nginx ngx_http_proxy_module.c Multiple Vulnerabilities

This script is Copyright (C) 2013-2014 Tenable Network Security, Inc.


Synopsis :

The remote web server is affected by multiple vulnerabilities.

Description :

According to its Server response header, the installed version of nginx
is 1.3.x, greater than or equal to 1.3.9, or 1.4.x prior to 1.4.1. It
is, therefore, affected by multiple vulnerabilities :

- A stack-based buffer overflow in 'ngx_http_parse.c' may
allow a remote attacker to execute arbitrary code or
trigger a denial of service condition via a specially
crafted HTTP request. This vulnerability only affects
versions greater than or equal to 1.3.9 and less than
1.4.1. (CVE-2013-2028)

- A memory disclosure vulnerability in 'ngx_http_parse.c'
affects servers that use 'proxy_pass' to untrusted
upstream servers. This issue can be triggered by a
remote attacker via a specially crafted HTTP request.
Failed attempts may result in a denial of service
condition. (CVE-2013-2070)

See also :

http://nginx.org/en/security_advisories.html
http://mailman.nginx.org/pipermail/nginx-announce/2013/000112.html
http://mailman.nginx.org/pipermail/nginx-announce/2013/000114.html

Solution :

Either apply the patch manually or upgrade to nginx 1.4.1 / 1.5.0 or
later.

Risk factor :

Critical / CVSS Base Score : 10.0
(CVSS2#AV:N/AC:L/Au:N/C:C/I:C/A:C)
CVSS Temporal Score : 8.7
(CVSS2#E:ND/RL:OF/RC:C)
Public Exploit Available : true

Family: Web Servers

Nessus Plugin ID: 66672 ()

Bugtraq ID: 59699
59824

CVE ID: CVE-2013-2028
CVE-2013-2070