This script is Copyright (C) 2013-2014 Tenable Network Security, Inc.
The remote web server is affected by multiple vulnerabilities.
According to its Server response header, the installed version of nginx
is 1.3.x, greater than or equal to 1.3.9, or 1.4.x prior to 1.4.1. It
is, therefore, affected by multiple vulnerabilities :
- A stack-based buffer overflow in 'ngx_http_parse.c' may
allow a remote attacker to execute arbitrary code or
trigger a denial of service condition via a specially
crafted HTTP request. This vulnerability only affects
versions greater than or equal to 1.3.9 and less than
- A memory disclosure vulnerability in 'ngx_http_parse.c'
affects servers that use 'proxy_pass' to untrusted
upstream servers. This issue can be triggered by a
remote attacker via a specially crafted HTTP request.
Failed attempts may result in a denial of service
See also :
Either apply the patch manually or upgrade to nginx 1.4.1 / 1.5.0 or
Risk factor :
Critical / CVSS Base Score : 10.0
CVSS Temporal Score : 8.7
Public Exploit Available : true