ClamAV < 0.97.8 Multiple Vulnerabilities

This script is Copyright (C) 2013-2014 Tenable Network Security, Inc.


Synopsis :

The antivirus service running on the remote host is affected by
multiple vulnerabilities.

Description :

According to its version, the ClamAV clamd antivirus daemon on the
remote host is earlier than 0.97.8 and is, therefore, potentially
affected by the following vulnerabilities :

- An overflow condition exists in the 'getsisstring()'
function in 'libclamav/sis.c' when handling SIS content.
This flaw reportedly only affects GNU/Linux.
(Issue 6808)

- A heap overflow exists in the 'libclamav/pdf.c' when
handling a specially crafted encrypted PDF file. This
flaw reportedly affects ClamAV 0.97.1 - 0.97.7 only.
(Issue 7053)

- A heap overflow exists in 'libclamav/pe.c' that is
triggered when handling a specially crafted UPX-packed
executable. (Issue 7055)

See also :

https://github.com/vrtadmin/clamav-devel/blob/0.97/ChangeLog
https://bugzilla.clamav.net/show_bug.cgi?id=6808
https://bugzilla.clamav.net/show_bug.cgi?id=7053
https://bugzilla.clamav.net/show_bug.cgi?id=7055

Solution :

Upgrade to ClamAV 0.97.8 or later.

Risk factor :

High / CVSS Base Score : 7.5
(CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P)
CVSS Temporal Score : 6.5
(CVSS2#E:ND/RL:OF/RC:C)
Public Exploit Available : false

Family: Misc.

Nessus Plugin ID: 66308 ()

Bugtraq ID: 59434
60118

CVE ID: CVE-2013-2020
CVE-2013-2021