VMware Security Updates for vCenter Server (VMSA-2013-0006)

This script is Copyright (C) 2013-2014 Tenable Network Security, Inc.


Synopsis :

The remote host has a virtualization management application installed
that is affected by multiple vulnerabilities.

Description :

The version of VMware vCenter installed on the remote host is 5.1 prior
to update 1. It therefore is potentially affected by the following
vulnerabilities :

- When deployed in an environment that uses Active
Directory with anonymous LDAP binding enabled, VMware
vCenter doesn't properly handle login credentials.
(CVE-2013-3107)

- The bundled version of Oracle JRE is earlier than
1.6.0_37 and thus, is affected by multiple security
issues.

- The bundled version of Apache Tomcat is affected by
multiple issues. (CVE-2012-2733, CVE-2012-4534)

See also :

http://www.vmware.com/security/advisories/VMSA-2013-0006.html
http://lists.vmware.com/pipermail/security-announce/2013/000209.html
http://www.nessus.org/u?b0eb44d4

Solution :

Upgrade to VMware vCenter 5.1 update 1 or later.

Risk factor :

Critical / CVSS Base Score : 10.0
(CVSS2#AV:N/AC:L/Au:N/C:C/I:C/A:C)
CVSS Temporal Score : 8.7
(CVSS2#E:ND/RL:OF/RC:C)
Public Exploit Available : true

Family: Misc.

Nessus Plugin ID: 66274 ()

Bugtraq ID: 56402
56813
59508

CVE ID: CVE-2012-2733
CVE-2012-4534
CVE-2013-3107