Privoxy < 3.0.21 Multiple Information Disclosure Vulnerabilities

This script is Copyright (C) 2013-2015 Tenable Network Security, Inc.

Synopsis :

The remote web proxy is affected by multiple information disclosure

Description :

According to its self-identified version number, the Privoxy installed
on the remote host is a version prior to 3.0.21. It is, therefore,
affected by multiple information disclosure vulnerabilities due to the
application not properly handling Proxy-Authenticate and
Proxy-Authorization headers. This can allow a remote, malicious HTTP
server to spoof the intended proxy service via a 407 (Proxy
Authentication Required) HTTP status code and thereby gain access to
user credentials.

Note that Nessus has not tested for these issues but has instead
relied only on the application's self-reported version number.

See also :

Solution :

Upgrade to version 3.0.21 or later.

Risk factor :

Medium / CVSS Base Score : 4.3
CVSS Temporal Score : 3.4
Public Exploit Available : true

Family: Firewalls

Nessus Plugin ID: 65948 ()

Bugtraq ID: 58425

CVE ID: CVE-2013-2503