Adobe AIR for Mac 3.x <= 3.6.0.6090 Multiple Vulnerabilities (APSB13-11)

This script is Copyright (C) 2013-2014 Tenable Network Security, Inc.


Synopsis :

The remote Mac OS X host contains a version of Adobe AIR that is
affected by multiple vulnerabilities.

Description :

According to its version, the instance of Adobe AIR 3.x on the remote
Mac OS X host is 3.6.0.6090 or earlier. It is, therefore, reportedly
affected by multiple vulnerabilities :

- Multiple memory corruption errors exist that could lead
to code execution. (CVE-2013-1378, CVE-2013-1379,
CVE-2013-1380)

- An integer overflow error exists that could lead to code
execution. (CVE-2013-2555)

See also :

http://www.adobe.com/support/security/bulletins/apsb13-11.html

Solution :

Upgrade to Adobe AIR 3.7.0.1530 or later.

Risk factor :

High / CVSS Base Score : 9.3
(CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C)
CVSS Temporal Score : 8.1
(CVSS2#E:ND/RL:OF/RC:C)
Public Exploit Available : true

Family: MacOS X Local Security Checks

Nessus Plugin ID: 65911 ()

Bugtraq ID: 58396
58947
58949
58951

CVE ID: CVE-2013-1378
CVE-2013-1379
CVE-2013-1380
CVE-2013-2555