PostgreSQL 9.1 < 9.1.9 / 9.2 < 9.2.4 Denial of Service

This script is Copyright (C) 2013-2014 Tenable Network Security, Inc.


Synopsis :

The remote database server is affected by a denial of service
vulnerability.

Description :

The version of PostgreSQL installed on the remote host is 9.1.x prior
to 9.1.9 or 9.2.x prior to 9.2.4. As such, it is potentially affected
by a denial of service vulnerability. An unprivileged user can run
commands that could interfere with in-progress backups.

See also :

http://www.postgresql.org/about/news/1456/
http://www.postgresql.org/docs/9.1/static/release-9-1-9.html
http://www.postgresql.org/docs/9.2/static/release-9-2-4.html
http://www.vmware.com/security/advisories/VMSA-2013-0005.html

Solution :

Upgrade to PostgreSQL 9.1.9 / 9.2.4 or later.

Risk factor :

Medium / CVSS Base Score : 4.0
(CVSS2#AV:N/AC:L/Au:S/C:N/I:P/A:N)
CVSS Temporal Score : 3.5
(CVSS2#E:ND/RL:OF/RC:C)
Public Exploit Available : false

Family: Databases

Nessus Plugin ID: 65857 ()

Bugtraq ID: 58878

CVE ID: CVE-2013-1901